Back to overview
Downtime
All services unavailable
Jun 27 at 09:18pm GMT+7
Affected services
mwit.link
tiny.mwit.link
Resolved
Jun 27 at 09:59pm GMT+7
All systems now operational
Affected services
Created
Jun 27 at 09:18pm GMT+7
All services (mwit.link, tiny.mwit.link) are down to to an issue with our VPS provider. We have contacted the provider to resolve this issue as soon as possible.
Affected services