Back to overview
Downtime

Datacenter is experiencing power issues again

Sep 04 at 01:27pm GMT+7
Affected services
mwit.link
tiny.mwit.link

Resolved
Sep 04 at 02:45pm GMT+7

Power appears to be restored. We will continue monitoring the situation.

Updated
Sep 04 at 02:07pm GMT+7

Power at the datacenter appears to have failed again.

Updated
Sep 04 at 02:00pm GMT+7

Power restored. Services back operational

Created
Sep 04 at 01:27pm GMT+7

Our VPS provider has informed us that the datacenter hosting the server is experiencing power problems again. No resolution ETA has been given.